What browsers are compatible with Spark Hire?

Spark Hire was developed to be compatible with the most recent versions of all major browsers (Mozilla Firefox, Google Chrome, Safari, Internet Explorer 9+).

To download Google Chrome, please visit http://www.google.com/chrome

To download Mozilla Firefox, please visit http://www.mozilla.org/en-US/firefox/new/

To download Safari, please visit http://www.apple.com/safari/

To download the latest version of Internet Explorer, please visit http://windows.microsoft.com/en-us/internet-explorer/download-ie



Feedback and Knowledge Base