What version of Flash should I run while using Spark Hire?

Spark Hire's most recent update now requires that individuals use Flash Player version 11 and up.

This will ensure that you are able to take full advantage of the high quality video features.

You can download the most recent version of Flash here: http://get.adobe.com/flashplayer/

Feedback and Knowledge Base